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Introduction to QGIS (version 2.18) and Geoprocessing using the 

Census of Canada 
Rebecca Bartlett, GIS & Digital Resources Librarian, October 2018 

1. Download Census Tracts shapefile and add to map document 
Census Tracts (CTs) are geographic areas in Census Metropolitan Areas (CMAs) that have a population of 

2500-8000. The data is downloaded as a shapefile which can then be viewed in QGIS. 

1) In an internet browser, go to statcan.gc.ca. 

2) After you’ve selected English, click Census program in the menu bar 

3) Scroll down and under Information and services, click on Geography 

4) Scroll down to Spatial information products and click Boundary files 

5) In Boundary files options, select English and ArcGIS (.shp) format 

6) Select census year 2016 

7) Click the radio button for Census tracts and Cartographic Boundary File then the Continue 

button 

8) Click the lct_000b16a_e.zip (ZIP Version, 8247.0 kb) link 

9) Once it has downloaded, copy the ZIP folder into the project folder for today’s class. We suggest 

a hierarchy like this, but we’re particular about this stuff: 

 
10) Unzip the file. If you don’t, you may get an error when you try to import it into QGIS. 

11) Once unzipped, your folder should look something like this: 

 
This is as good a time as any to note that shapefiles look like multiple different files when you 

view them in Windows Explorer. If you ever copy and paste them somewhere, you need to have 

all the parts (e.g.: all the files that have the same name before the file extension – there may be 

http://www.statcan.gc.ca/
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up to 8 of them). For more on shape files, please consult pages 121 and 148 of The Data 

Journalist.  

12) You’re done the download!  

13) Open QGIS. Once QGIS opens, add the dataset by clicking on Layer > Add Layer > Add Vector 

Layer… Browse to the project’s folder and find the shapefile. Click on the .shp and click Ok to 

add the shapefile to QGIS. 

a. You could also have the project folder open in Windows Explorer and just drag and drop 

the .shp file in. Either way works! 

14) You’ll notice that much of the country is missing – this is normal! Remember that census tracts 

are only in cities with a population of over 100,000. 

 

15) Click View >Panels and make sure Browser and Layers are both selected. If one of those options 

is unselected, then check the box beside it so the panel appears in the menu to the left.  

16) Because we will want our map to look reasonably nice, let’s follow steps 1-13 except download 

the Provinces/territories, Cartographic Boundary File and unzip it and add it to QGIS. Your map 

should now look something like this: 
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17) If you’re wondering why the census tracts seem to have disappeared, it’s because that layer is 

below the provinces/territories layer in the Layers Panel: 

 
18) Click and drag lct_000b16a_e above the provinces/territories layer to view it on top. The layers 

always show top to bottom. You can also turn the layers on and off with the checkbox. 

2. Ensuring the data can be joined 
In order to join the CT shapefile and the CT data text files, we need to have a field that includes 

identical data. For example, it’s not possible to join a text (string) field to a number field. Specifically, in 

this case, the CT identification numbers have decimals (.00, .01, etc.) and those are critical. We need to 

make sure those fields are both numeric and have 2 decimal places for each entry. 

1) Right-click the lct_000b16a_e shapefile and select Properties, then click the Fields tab 

2) Note that the CTUID field is type QString. This means it’s a text field and we want it to be a 

numeric field. 

3) Click the Open field calculator button  

a. Make sure Create a new field is checked 

b. In Output field name, enter CTUIDnum 
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c. Output field type needs 

to be Decimal number 

(real) 

d. Output field length is 10, 

Precision is 2 

i. Length is how 

many digits are 

in the number, 

and precision is 

how many digits 

appear after the 

decimal; we 

want .00 to 

show up for 

whole numbers 

so we’ll force 

that precision by 

giving it a value 

of 2 

e. In the Expression area, click Fields and Values and then double-click CTUID  

f. Click OK 

 

4) In the list of fields, you should see a new field on the bottom called CTUIDnum 

5) Click Toggle editing mode (pencil icon) to stop editing and close the attribute table – this may 

take a few moments. Also, be sure to save the entire project after each step.  

6) Now, we need to do the same thing for “CT_DATA_CF_PHH_2011_2016.txt” file which can be 

downloaded from a zipped folder by clicking here. Before moving to the following step, it’s 

worth cautioning that working with this file is a bit more involved. 

7) In QGIS, go to Layer > Add Layer > Add Delimited Text Layer 

8) Browse to the file in the “CT_DATA_CF_PHH_2011_2016.txt”  

a. File format: CSV 

b. Geometry definition: No geometry (attribute table only) 

c. Click OKAY. When the file shows up in the Layers window, close the delimited text dialog 

box. 

http://www.davidmckie.com/CT_DATA_CF_PHH_2011_2016.zip
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d.  

 
In order to reformat the ID column, as we did in steps 1-5, we must export this file by 

following the next steps:  

9) To export to CSV, right-click on CT_DATA_CF_PHH_2011_2016.txt > Export > Save features as… 

a. Format: Comma Separated Value 

b. File name: CT_DATA_CF_PHH_2011_2016.txt_New.csv 

c. Rename the file to something like “DwellingCounts_2016_forQGIS” 

d. Click the arrow beside Select fields to export and their export options and choose 

which fields you’d like to export. In this case, we can keep all of them.  

e. The Add saved file to map option should already be selected, if not, do so.  

f. Click the arrow beside Geometry and in the drop-down list, select No Geometry 

g. Use the vertical scroll bar to the right to obtain “Layer options” 

h. At the “CREATE_CSVT” prompt, select “YES” 

i. See image below to ensure you’ve selected the correct options, then click OK  
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10) Delete the old txt file from your menu, and open the attribute table for your new csv file. 

11) Repeat steps 1-5, except you want to copy the values in the CT_UID field, so the result should 

look like this. 
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12) Toggle the Edit button (remember, it may take a few moments to process) and close the 

Properties dialog box. 

3. Joining Census Data 
We’re at the most critical point! Attention to detail is key. 

1) Right click on the lct_000b16a_e polygon file and select Properties. 

2) Click Joins, then click the green plus sign 

3) Ensure that join of the table data to the polygon is based on a common field. In this case, it’s 

CT_UID_NEW and CTUIDnum which are the unique census tract identification numbers that we 
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just made sure are numeric and have all the required decimal places. 

 

 

4) Check off Custom field name prefix then click the down arrow. Enter something short, like 

Dw2016_ 

a. If the prefix is long, it will take up the entire field name when exported later on and it’ll 

be difficult to tell which data the field contains 

5) Click OK. Then Apply. Then Close. 

6) Right-click on the CT shapefile to check that the join worked. You should see data added to the 

attribute table: 
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4. Querying and Extracting 
When confronted with a large dataset you may want to use the querying capabilities of QGIS to extract 

one or more subsets. 

1) Right click on the lct_00616a_e and select Open Attribute Table. 

2) You will note that there are 5721 features in the dataset.  

 



Prepared by Rebecca Bartlett & David McKie, October 2018 11 

3) In order to query the data, click on the Select features using an expression button  on 

the attribute table toolbar.  

4) The Select by expression dialog box will appear. It allows you to create a query statement that 

will select features that conform to the parameters you set. In this example, we will search for 

only Ottawa census tracts by using the CMAPUID field. 

a. Start off by making the Select by expression dialog box wider. It will make sense shortly. 

b. In the middle window, click the + sign beside Fields and Values to see all the fields in 

the attribute table. 

c. Double-click CMAPUID. It will show up in the Expression window.  

d. Select the “=”  

e. Census Metropolitan ID field for Ottawa is the number 35505 

f. On the right, beside Load values click the all unique button. 

 
g. Double-click on the number 35505 from the list. 
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h. Click the Select button to the bottom right. 

 
i. Click Close. 

j. In the bottom left of the attribute table, you can click the Show All Features button and 

select Show Selected Features instead.  

 
k. Close the attribute table. 

5) The selected features are only temporary and we want to deal ONLY with the Ottawa CTs, so 

we’ll export the currently-selected census tracts to a new shapefile. 

a. Right-click on lct_000b16a_e and select Save As… from the menu 

b. Before you do anything else, select the Save only selected features option. 
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c. Browse to where you would like to save your file. We recommend naming it something 

helpful, such as CT_Ottawa_Population.shp. Ensure that you save as type ESRI 
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Shapefile   

 
d. Click Save and then OK in the “Save vector layer as” dialog box. 

e. Wait a moment for it to export and add the file. 

f. Right-click on lct_000b16a_e and select Remove. 
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g. Right-click on CT_Ottawa_Population file and select Zoom to layer. 

 

5. Creating new column heads or “aliases”  
1) If you open the attribute table, you’ll notice that the new layer joining the census tracts to the 

data has names for the columns that contain the data we will “symbolize” in the next section. 

This is because QGIS can’t handle long titles. We could have shortened the titles in the original 

csv file. But we can also follow these steps to achieve the same ends.  

2) If you can’t remember the column names, you can use the original csv or txt file as a reference.  

3) Open the new CT_Ottawa_Population layer to open the Properties option 
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4) Select “Fields” from the menu to the left of the dialogue box. 

 
5) You can type new – and shortened – field names into the “Alias” column 
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6) Select Apply, then OK. And open the attribute table. Be sure to save your project after each 

step. 

 
7) Now we can symbolize! 

6. Symbology 
1) To symbolize right-click on the CT_Ottawa_Population  and select Properties. 

2) Click the Style tab in the Layer Properties dialog box. 

3) Click Graduated in the drop-down box at the top 

4) For Column, select Households%Diff 
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5) Select a colour ramp, then click the Classify button 

 
6) It should be filled in as you see below: (NOTE: depending on your version of QGIS, your dialog 

box may look slightly different.) 
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a. Column should be Households%Diff ( since the new name is only an alias, it won’t be 

displayed in the “Column” box of the layer properties dialog box. 

 
b. Under the Classes tab, Mode should be Natural Breaks (Jenks) with 5 classes 

i. You can play around with this if you’d like 

c. Pick your favourite colour ramp. As you are showing intervals, go with something that’s 

the same hue, but with varying intensity. If you go with a many-coloured ramp your map 

becomes meaningless, like so: 

 

7) Your on-screen map should now look something like this, with the darker hues showing us which 

CTs have higher and lower population changes. 
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8) You can also manually adjust the intervals. For example, you can set the classes to 5 and then 

edit the values to reflect rounder numbers, like so: 

 
You can also edit the legend text, as you can see above. 

8. Creating a Map Layout 
To create a map layout in QGIS, you need to make a Composer. This will enable you to place and arrange 

map elements such scale bar, a legend, and a map title.  

1) Start off by right-clicking the layer you want to create a layout for, and select Zoom to layer. 

2) In the menu, select Project > New Print Composer.  

3) In the Composer title dialog box, give your new composition a name. Click OK. 

4) A new Composer window will appear. To add your map of CTs, click Layout > Add Map, then 

draw a box that is just inside the perimeter of the page. 
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5) Under Item Properties tab, under Extents, click the Set to map canvas extent button to centre 

the layer. 

6) If the CTs are either too large or too small for your liking, fiddle with the Scale under Item 

properties on the right.  

a. A larger number will make the CTs smaller and a smaller number will make the CTs 

larger. 

7) The QGIS composer is remarkably finicky. Maneuver (including deleting and re-adding) the map 

around until you’re reasonably satisfied. 

Adding Other Map Elements 

Adding a Legend 

1. In the menu, select Layout > Add Legend.  

2. Draw a box where you would like your legend to appear. 

3. By default, all the layers on the map will appear as legend items in the legend.  

4. To remove a legend item, you need to uncheck the Auto update checkbox and then 

manually remove the layers you don’t want in your legend using the red minus 

button.  

5. To change the name of a legend item as it shows up in the legend, click the 

legend item and then the Edit button to change its title in the legend.  

6. If you would like to change the title of your legend (or prefer that it doesn’t have a title at all), 

change it in the Title textbox under Main properties. 

7. There are a lot of options in the Legend panel, from font selections to spacing to background 

colour. 
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8. You can click and drag the legend into place on your map. 

Adding a North Arrow 

1. In the menu, select Layout > Add Image. 

2. Draw a box where you would like to see your north arrow. 

3. In the Item properties panel on the right, click on the Search Directories submenu, and under 

Image search paths find the one ending in /arrows. 

4. Select an arrow that meets your needs. You could always design your own if you feel creative, or 

just go for a Star Trek vibe (never a bad idea): 

 

Adding a Scale Bar 

1. In the menu, select Layout > Add Scalebar. 

2. Draw a box where you would like to see the scale bar. 

3. In the Item properties tab, you can select one of six styles under the Style dropdown. 

4. Choose the units for the scale bar under Units. 

5. Adjust the segments in the Segments area. 

a. E.g.: left 0 and right 4 on a Line Ticks Up style will look something like this: 

 
6. Click and drag the scale bar into place on your map.  

Adding a Title to a Map 

1. In the menu, select Layout > Add Label. 

2. Draw a box where you’d like your title to be (you 

can move it later). 

3. Type your title into the Main properties text box. 

4. Adjust the font as you see fit and move it around 

until you resign yourself to the lack of design 

elements included in QGIS. 

 This is not a very pretty map. You can make a nicer one. 


